Frequent Queries

Digital Banking (Maybank2u App)

Requirement (iOS)

  • Compatibles with iPhone, iPad and iPod Touch
  • Requires iOS 6.0 onwards

 

Requirement (Android)

  • Compatibles with most smartphones and tablets
  • Requires Android 4.0 onwards

Download Maybank app via:

  

 

Services Available For M2U Mobile Users